123456789_123456789_123456789_123456789_123456789_

Class: RuboCop::Cop::Gemspec::RequiredRubyVersion

Relationships & Source Files
Super Chains via Extension / Inclusion / Inheritance
Class Chain:
self, ::RuboCop::Cop::Base, ::RuboCop::ExcludeLimit, NodePattern::Macros, RuboCop::AST::Sexp
Instance Chain:
Inherits: RuboCop::Cop::Base
Defined in: lib/rubocop/cop/gemspec/required_ruby_version.rb

Overview

Checks that required_ruby_version in a gemspec file is set to a valid value (non-blank) and matches TargetRubyVersion as set in RuboCop’s configuration for the gem.

This ensures that RuboCop is using the same Ruby version as the gem.

Examples:

# When `TargetRubyVersion` of .rubocop.yml is `2.5`.

# bad
Gem::Specification.new do |spec|
  # no `required_ruby_version` specified
end

# bad
Gem::Specification.new do |spec|
  spec.required_ruby_version = '>= 2.4.0'
end

# bad
Gem::Specification.new do |spec|
  spec.required_ruby_version = '>= 2.6.0'
end

# bad
Gem::Specification.new do |spec|
  spec.required_ruby_version = ''
end

# good
Gem::Specification.new do |spec|
  spec.required_ruby_version = '>= 2.5.0'
end

# good
Gem::Specification.new do |spec|
  spec.required_ruby_version = '>= 2.5'
end

# accepted but not recommended
Gem::Specification.new do |spec|
  spec.required_ruby_version = ['>= 2.5.0', '< 2.7.0']
end

# accepted but not recommended, since
# Ruby does not really follow semantic versioning
Gem::Specification.new do |spec|
  spec.required_ruby_version = '~> 2.5'
end

Constant Summary

::RuboCop::Cop::Base - Inherited

EMPTY_OFFENSES, RESTRICT_ON_SEND

::RuboCop::Cop::RangeHelp - Included

BYTE_ORDER_MARK, NOT_GIVEN

Class Attribute Summary

::RuboCop::Cop::Base - Inherited

.gem_requirements, .lint?,
.support_autocorrect?

Returns if class supports autocorrect.

.support_multiple_source?

Override if your cop should be called repeatedly for multiple investigations Between calls to on_new_investigation and on_investigation_end, the result of processed_source will remain constant.

Class Method Summary

::RuboCop::Cop::Base - Inherited

.autocorrect_incompatible_with

List of cops that should not try to autocorrect at the same time as this cop.

.badge

Naming.

.callbacks_needed, .cop_name, .department,
.documentation_url

Returns an url to view this cops documentation online.

.exclude_from_registry

Call for abstract Cop classes.

.inherited,
.joining_forces

Override and return the Force class(es) you need to join.

.match?

Returns true if the cop name or the cop namespace matches any of the given names.

.new,
.requires_gem

Register a version requirement for the given gem name.

.restrict_on_send

::RuboCop::ExcludeLimit - Extended

exclude_limit

Sets up a configuration option to have an exclude limit tracked.

transform

Instance Attribute Summary

Instance Method Summary

::RuboCop::Cop::RangeHelp - Included

#add_range, #column_offset_between,
#contents_range

A range containing only the contents of a literal with delimiters (e.g.

#directions,
#effective_column

Returns the column attribute of the range, except if the range is on the first line and there’s a byte order mark at the beginning of that line, in which case 1 is subtracted from the column value.

#final_pos, #move_pos, #move_pos_str, #range_between, #range_by_whole_lines, #range_with_comments, #range_with_comments_and_lines, #range_with_surrounding_comma, #range_with_surrounding_space, #source_range

::RuboCop::Cop::Base - Inherited

#add_global_offense

Adds an offense that has no particular location.

#add_offense

Adds an offense on the specified range (or node with an expression) Unless that offense is disabled for this range, a corrector will be yielded to provide the cop the opportunity to autocorrect the offense.

#begin_investigation

Called before any investigation.

#callbacks_needed,
#cop_config

Configuration Helpers.

#cop_name, #excluded_file?,
#external_dependency_checksum

This method should be overridden when a cop’s behavior depends on state that lives outside of these locations:

#inspect,
#message

Gets called if no message is specified when calling add_offense or add_global_offense Cops are discouraged to override this; instead pass your message directly.

#name

Alias for Base#cop_name.

#offenses,
#on_investigation_end

Called after all on_…​

#on_new_investigation

Called before all on_…​

#on_other_file

Called instead of all on_…​

#parse

There should be very limited reasons for a Cop to do it’s own parsing.

#parser_engine,
#ready

Called between investigations.

#relevant_file?, #target_rails_version, #target_ruby_version, #annotate, #apply_correction, #attempt_correction,
#callback_argument

Reserved for Cop::Cop.

#complete_investigation

Called to complete an investigation.

#correct, #current_corrector,
#current_offense_locations

Reserved for Commissioner:

#current_offenses, #currently_disabled_lines, #custom_severity, #default_severity, #disable_uncorrectable, #enabled_line?, #file_name_matches_any?, #find_message, #find_severity, #range_for_original, #range_from_node_or_range,
#reset_investigation

Actually private methods.

#use_corrector

::RuboCop::Cop::AutocorrectLogic - Included

::RuboCop::Cop::IgnoredNode - Included

Constructor Details

This class inherits a constructor from RuboCop::Cop::Base

Instance Method Details

#defined_ruby_version(node)

[ GitHub ]

  
# File 'lib/rubocop/cop/gemspec/required_ruby_version.rb', line 70

def_node_matcher :defined_ruby_version, <<~PATTERN
  {
    $(str _)
    $(array (str _) (str _))
    (send (const (const nil? :Gem) :Requirement) :new $str+)
  }
PATTERN

#dynamic_version?(node) ⇒ Boolean (private)

[ GitHub ]

  
# File 'lib/rubocop/cop/gemspec/required_ruby_version.rb', line 96

def dynamic_version?(node)
  (node.send_type? && !node.receiver) ||
    node.variable? ||
    node.each_descendant(:send, *RuboCop::AST::Node::VARIABLES).any?
end

#extract_ruby_version(required_ruby_version) (private)

[ GitHub ]

  
# File 'lib/rubocop/cop/gemspec/required_ruby_version.rb', line 102

def extract_ruby_version(required_ruby_version)
  return unless required_ruby_version

  if required_ruby_version.is_a?(Array)
    required_ruby_version = required_ruby_version.detect do |v|
      /[>=]/.match?(v.str_content)
    end
  elsif required_ruby_version.array_type?
    required_ruby_version = required_ruby_version.children.detect do |v|
      /[>=]/.match?(v.str_content)
    end
  end

  return unless required_ruby_version

  required_ruby_version.str_content.scan(/\d/).first(2).join('.')
end

#not_equal_message(required_ruby_version, target_ruby_version) (private)

[ GitHub ]

  
# File 'lib/rubocop/cop/gemspec/required_ruby_version.rb', line 120

def not_equal_message(required_ruby_version, target_ruby_version)
  format(
    NOT_EQUAL_MSG,
    required_ruby_version: required_ruby_version,
    gemspec_filename: File.basename(processed_source.file_path),
    target_ruby_version: target_ruby_version
  )
end

#on_new_investigation

[ GitHub ]

  
# File 'lib/rubocop/cop/gemspec/required_ruby_version.rb', line 78

def on_new_investigation
  return if processed_source.ast && required_ruby_version?(processed_source.ast)

  add_global_offense(MISSING_MSG)
end

#on_send(node)

[ GitHub ]

  
# File 'lib/rubocop/cop/gemspec/required_ruby_version.rb', line 84

def on_send(node)
  version_def = node.first_argument
  return if dynamic_version?(version_def)

  ruby_version = extract_ruby_version(defined_ruby_version(version_def))
  return if ruby_version == target_ruby_version.to_s

  add_offense(version_def, message: not_equal_message(ruby_version, target_ruby_version))
end

#required_ruby_version?(node)

[ GitHub ]

  
# File 'lib/rubocop/cop/gemspec/required_ruby_version.rb', line 65

def_node_search :required_ruby_version?, <<~PATTERN
  (send _ :required_ruby_version= _)
PATTERN